SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April 12)

Moderators: Omen, Abe

Forum rules
For Search Purposes Only.. Any Violation Will Be Punished With "Death By Mugumba!"

THE GRACKLE
Insomniac
Posts: 763

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#31 » Thu Apr 12, 2012 12:37 pm

Thanks for the effort Iszazial but I still cannot break the 150kb/sec barrier with rapid pro. Been that way since the last 2 iqs updates. Might be my issue only.
Some people are so fond of ill luck they run halfway to meet it

User avatar

Russtronic™
Jeddak
Posts: 7343
Contact:

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#32 » Thu Apr 12, 2012 1:23 pm

I am sorry Gra I just woke up from the meds I will send A Link for the fix to every one that needs it! I have did this 3 updates ago tried to tell them but it fell on deaf ears
Here is the link for the fix I haven't finished finding the Last problem if you get a Flash Player error click the disable in the error box and all will be well they are trying to get all to work I will spend the Day refining this but it Works right now...

http://userscripts.org/scripts/show/130318
Image

User avatar

Topic Author
iszazial
Average User
Posts: 74

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#33 » Thu Apr 12, 2012 1:35 pm

THE GRACKLE wrote:Thanks for the effort Iszazial but I still cannot break the 150kb/sec barrier with rapid pro. Been that way since the last 2 iqs updates. Might be my issue only.


I just finished testing it with both chrome and firefox with positive results. So a good question to ask would be is the aforementioned 150kb/sec barrier consistent or does it frequently start and stop? If it is consistent downloading at 150kbps then this is a problem likely on your end with your connection. If however it starts and stops over and over which is a symptom of the script unable to obtain premium status then double check the script installed correctly.

Here are a couple common things to look for.
-In firefox look at which scripts are enabled in greasemonkey and disable all but the new IQS you just installed
-In chrome try removing the old script before installing the new one


Russtronic wrote:I am sorry Gra I just woke up from the meds I will send A Link for the fix to every one that needs it! I have did this 3 updates ago tried to tell them but it fell on deaf ears
Here is the link for the fix I haven't finished finding the Last problem if you get a Flash Player error click the disable in the error box and all will be well they are trying to get all to work I will spend the Day refining this but it Works right now...

http://userscripts.org/scripts/show/130318


I was looking through your script and saw that you reverted all the changes made to rapidshare from IQS 4.94 to 4.91. I actually did this originally but then found it to be a redundant change because the only lines that inter-fear with the premium link grab is on lines 518-519 as I pointed out a while back.

Code: Select all

         if (document.getElementById('pro-area').className.indexOf("has-pro")>-1
          && document.cookie.indexOf("enc=")>-1


The above lines modified to:

Code: Select all

         if (document.cookie.indexOf("enc=")>-1
Image

User avatar

Russtronic™
Jeddak
Posts: 7343
Contact:

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#34 » Thu Apr 12, 2012 2:23 pm

Actually the changes go back a lot farther I would have to go to my Laptop for those notes, if you follow what is happening this one works.. I am using the Last Good script .. Have you tried this? I am not in any Competition.... I am just trying to help..
This one works Great with any RS link. I have had twice (Out of 30+ shows) a Flash Player Script Error. Haven't figured that one out yet.
Image


THE GRACKLE
Insomniac
Posts: 763

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#35 » Thu Apr 12, 2012 11:11 pm

Iszazial

Manually uninstalled IQS then installed your script. Tested on the latest Greys Anatomy and was able to reach 110kbs/sec on a download. As to does the speed jump up and down or stop? No It putzes along at a staid 80 to 90 kbs/sec jumping to 150 on occasion. 2 weeks ago between 1000 and 2000 kbs/sec was the norm.

Russ

Uninstalled then installed your script from the link provided. Cannot get to the mainsite now but when I can I will give you the results. Will test on the same link.

To both of you. Thank You!
Some people are so fond of ill luck they run halfway to meet it

User avatar

Topic Author
iszazial
Average User
Posts: 74

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#36 » Thu Apr 12, 2012 11:18 pm

I actually responded because I was interested in some of the other changed in the script and rather curious about your thoughts on them. I'm curious about what you mean about a flash player problem? is this pertaining to RS links? and are you using webdivx or an alternative?
I personally been experimenting with a script that loads standalone VLC player by using opening a CMD batch file. This is where I think the future is as the script is only a few lines and the batch file does the rest so to speak. I will be excited to finish this script and show everyone when I'm done. What do you think?

THE GRACKLE wrote:Manually uninstalled IQS then installed your script. Tested on the latest Greys Anatomy and was able to reach 110kbs/sec on a download. As to does the speed jump up and down or stop? No It putzes along at a staid 80 to 90 kbs/sec jumping to 150 on occasion. 2 weeks ago between 1000 and 2000 kbs/sec was the norm.


Sounds like your having connection problems. This site here will verify if this is the case:
http://www.speedtest.net

at about 100kbps download I would suspect the results you will get from that site with be similar. Make sure you test rapidshare right after aswell so we can eliminate if time of day is an issue.

here is an example of my results.
From rapidshare I download at around 2Mbps to 6Mbps with the results below.
Image
Image

User avatar

Russtronic™
Jeddak
Posts: 7343
Contact:

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#37 » Fri Apr 13, 2012 3:53 am

I haven't messed with it any more but I had a thought and I will tom it may be to Fast.. LOL Yes I did. 1 that went directly to vlc, but that was an older player, this new one is FAR FAR superior, the one I did was a disaster! That's why I stopped messing with it, that was a couple yrs ago anyway.
It's fun to mess with isn't it?
Image


THE GRACKLE
Insomniac
Posts: 763

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#38 » Fri Apr 13, 2012 2:11 pm

Iszazial

Your script working the best. Pro speeds to 160kb/sec. Not good but usable, it must be something on my end.

Russ

With your scrip RS page loads, then loads again, then again and so on.

Mainsite page script.

Rapid treats me like a free user.
Some people are so fond of ill luck they run halfway to meet it

User avatar

Russtronic™
Jeddak
Posts: 7343
Contact:

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#39 » Fri Apr 13, 2012 2:18 pm

Yes I noticed that once I refreshed my browser on the main and went back and it loaded at 600-1.2M Streams slow starting but then ramps up to 700k
Image

User avatar

Way
RedTek
Posts: 3187

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#40 » Fri Apr 13, 2012 11:50 pm

I actually responded because I was interested in some of the other changed in the script and rather curious about your thoughts on them. I'm curious about what you mean about a flash player problem? is this pertaining to RS links? and are you using webdivx or an alternative?
I personally been experimenting with a script that loads standalone VLC player by using opening a CMD batch file. This is where I think the future is as the script is only a few lines and the batch file does the rest so to speak. I will be excited to finish this script and show everyone when I'm done. What do you think?



I have asked this before but it did not work at that time it may be ready now or it should be long time after the thought of it ... now make it work ;)

User avatar

Topic Author
iszazial
Average User
Posts: 74

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#41 » Tue Apr 17, 2012 11:13 am

this is the code that allows me to access batch files from javascript. It was really the most difficult bridge to pass but once the batch file is open it can access VLC internal commands, since vlc can open just about anything moving forward should be rather simple.

Code: Select all

function runCmd(command, option)
{
    var char34 = String.fromCharCode(34);
    var wsh = new ActiveXObject('WScript.Shell');
    if (wsh)
    {
        command = 'cmd /k ' + char34 + wsh.ExpandEnvironmentStrings(command) + ' ';
        command = command + char34 + wsh.ExpandEnvironmentStrings(option) + char34  + char34;
        if (confirm(command))
        {
            wsh.Run(command);
        }
    }
}


I however for see that most antivirus programs would see this as malicious or suspicious prompting a false positive unless modded otherwise but i guess we will have to see.
Image


jeeha89
meh
Posts: 16

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#42 » Wed Apr 18, 2012 8:57 am

i got the same problem again after i updated to 4.96 :(


jeeha89
meh
Posts: 16

Re: SOLVED! IQS 4.94 Slow/Fails With Rapid Pro (Update:April

Post#43 » Wed Apr 18, 2012 9:02 am

woops! disregard my last post. I was out of rapids :P

Return to “IQS”

Who is online

Users browsing this forum: No registered users and 1 guest